Why does a “git push” just hang there indefinitely using MySysGit 1.7.4?

Spread the love

Question Description

I tried small experiments with Ruby and Rails, and would like to push and pull from the Mac to PC and vice verse.

So I installed what the Git’s website’s standard recommended Git on PC (MySysGit 1.7.4), and run

git daemon --reuseaddr --base-path=. --export-all --verbose --enable=receive-pack

either on the Mac or PC (to start a Git server), and then, on the PC, I cloned and add a file, and commit, and then do a

git push git://192.168.1.31/ master

now it will print out the following and just hang there indefinitely:

Counting objects: 5, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (4/4)

I tried it on another PC, and it is the same thing. How can this be fixed?

(I am using the command to run the server from question: ‘receive-pack’: service not enabled for ‘./.git’)

Practice As Follows

They have just released a version that allows a config option to stop git hanging.

Fix is for https://github.com/msysgit/git/issues/101 in release https://github.com/msysgit/msysgit/releases/tag/Git-1.9.4-preview20140611

You can fix it by setting

git config --global sendpack.sideband false
Tags

Not what you're looking for? Browse other questions tagged

Leave a Comment