downgrading rails 4 to 3.2

Spread the love

Question Description

I have the Rails 4.0.0.beta1 installed but I need downgrade to Rails 3.2.13.

I’ve used gem install rails 3.2 but Rails continues as 4.0.0.beta1.

I searched existing doubts and try to follow the answers however none worked for me.

Think this is a simple doubt and I need to solve.


This answer my question: How to set default rails version for a project?

Practice As Follows

You have the same problem as listed here.

Here is what worked for me, and should also for you. It’s a more general solution that works regardless of your specific version of the Rails beta. Please note that in order to shift back to 3.2.13 (or whatever version you’d like to go back to), you must remove Railties as well as Rails.

Just do:

gem uninstall rails

Then, select the version of Rails 4 you have and delete it.

Then, do:

gem uninstall railties

And do the same thing.

When I uninstalled the Rails 4 version of railties, it told me that dependencies for a couple gems (coffee-rails and sass-rails) wouldn’t be met. So I just did the same thing with both of them as I did above, and deleted their Rails 4 versions as well (for example, for sass-rails, I had a version installed called sass-rails-4.0.0.rc1).

And done! The terminal should list 3.2.13 as your current Rails version.

Leave a Comment