Bootstrap’s javascript works locally but not when deployed to a server

Spread the love

Question Description

I downloaded the barebone example of Twitter’s bootstrap and customized it. I tested it locally (with WAMP server) and everything works perfectly, both the CSS and the JScript.

I uploaded the files to my webhosting service and the JScript just doesn’t work. I noticed it because dropdown boxes stopped working.

I searched and found other persons with the same problem but they all are using ruby and I’m not. Just the play CSS+JScript provided by bootstrap. Besides they said the solution was to include the bootstrap.js first and then the jquery.js. Well I tried it and it didn’t work, I even included the not minified .js and still it didn’t work.

I’m using the same browser (Chrome) for local and remote testing. I also tried different hosting services and the problem occurred in both.

Help is much appreciated.


Other similar questions:

Practice As Follows

I know this is very strange but I think I got the solution. Previously I was using the (supplied) jQuery 1.7.2 minified. Now I changed it to use the jQuery 1.8.0 not minified. It just started to work… Another thing I did was to convert all files’ encoding to UTF8 (I think this was the real problem/solution)

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.