auto indentation on common lisp emacs + slime + sbcl in windows

Spread the love

Question Description

I can’t use auto indentation function on emacs + slime + sbcl when I define my function and so on.

My .emacs file configuration is this:

(setq inferior-lisp-program
"D:/emacs/sbcl_1.0.37/sbcl.exe"
      lisp-indent-function 'common-lisp-indent-function
      slime-complete-symbol-function 'slime-fuzzy-complete-symbol
      slime-startup-animation nil
      slime-enable-evaluate-in-emacs t
      slime-log-events t
      slime-outline-mode-in-events-buffer nil
      slime-repl-return-behaviour :send-only-if-after-complete
      slime-autodoc-use-multiline-p t
      slime-highlight-compiler-notes t)

(add-to-list 'load-path
 "d:/emacs/site-lisp/slime")  ; your SLIME directory
(require 'slime)
(slime-setup)

Can someone help me?

Practice As Follows

The slime section in my .emacs:

;;; SLIME
(setq inferior-lisp-program "/usr/bin/sbcl")
(add-to-list 'load-path "/usr/share/emacs/site-lisp/slime/")
(require 'slime)
(require 'slime-autoloads)
(slime-setup '(slime-fancy))
(global-set-key "\C-cs" 'slime-selector)

Leave a Comment